Wave Systems offers a free evaluation version of our TCG-Enabled Cryptographic Service Provider (CSP) developer's kit which allows developers to easily enable their applications to utilize the enhanced hardware-based security of a Trusted Platform. A Trusted Platform is defined as one conforming to Trusted Computing Group (TCG) standards and containing a Trusted Platform Module (TPM) security chip.

By using Wave's TCG-Enabled CSP, an application developer enables TPM-based security through the standard MSCAPI interface without needing to understand vendor-specific requirements regarding the TCG Software Stack (TSS). The TSS is the software on a Trusted Platform that sits between the secure applications and the hardware.

Key Features

By using Wave's TCG-Enabled CSP, application developers can now:

  • Write an application directly to MSCAPI, utilizing the resident Microsoft OS on the platform, the TSS, and the TPM for cryptography operations.
  • Maintain a common user experience independent of the platform.
  • Enable the computing marketplace by providing compatibility across different manufacturer's TCG Software Stacks (TSS) implementations and versions.
  • Extend the value of trusted platforms through the enhanced security provided by the TPM module.
  • Achieve immediate disaster recovery and platform replacement capability through compatibility with Wave's TCG-based products.

<h2>
Supported TPM Manufacturers</h2>
<ul>
<li>
Nuvoton</li>
<li>
Atmel</li>
<li>
Infineon Technologies</li>
<li>
STMicroelectronics</li>
<li>
Broadcom</li>
</ul>
<h2>
Special Note</h2>
<p>In order to use the Wave TCG-Enabled CSP, please ensure that you have one of the compatible platforms and that the TPM is activated per the manufacturer&#39;s instructions. This offer is for a single copy of the Wave TCG-Enabled CSP. A distribution agreement is required to ship the Wave TCG-Enabled CSP with 3rd-party products. The evaluation version is for Windows XP or Windows Vista. This CSP version does not support Lenovo&#39;s CSS 8.0 or TPM v1.2 on a Lenovo platform with CSS 7.0 or below. For Windows XP, .NET Framework Version 2.0 Redistributable is required. For Windows Vista, Visual C++ 2005 Runtime Redistributable is required. Please verify before installing the Wave TCG-Enabled CSP. These packages can be downloaded from the Microsoft website.</p>