Problem: 

How to obtain the EMBASSY Trust Suite software and instructions for the installation process are unknown.

Applies To: 

EMBASSY Trust Suite version 2.2.3 installed on:

Latitude D420, D620, D820

Precision M65, M90, 490, 690 WS390

OptiPlex 530, 730

(XP and Vista 32-bit OS only)
 

See Solution: Dell EMBASSY Trust Suite

 

EMBASSY Trust Suite 3.3.0.26 installed on:

Latitude D430, D530, D531, D630(ATG, c, XFR), D631, D830, XT

Precision Mobile M65, M90, M2300, M4300, M6300
Precision WorkStation 390, T3400, R5400, T5400

OptiPlex 740, 745, 745c, 755

(XP and Vista 32-bit OS only)

See Solution: Dell EMBASSY Trust Suite

 

EMBASSY Trust Suite – Acer Edition Versions 7.3.4.7 (32 bit), 7.3.4.9 (64 bit) installed on Acer ProShield with TPM: BXD50/BAP50

See Solution: EMBASSY Trust Suite – Acer Edition

 

EMBASSY Trust Suite – Asus Edition PBA 7.5.2.63 (32 bit) PBA 2.5.2.23 (64 bit) installed on Asus models B53F, B53J, B43F, B43J

See Solution: EMBASSY Trust Suite Asus Edition

 

EMBASSY Trust Suite – Enterprise (Purchased Full) Edition- Version 7.5.2.60 installed on most enterprise PC’s equipped with a Trusted Platform Module (TPM).

See Solution: EMBASSY Trust Suite – Enterprise Edition

Solution: 

Dell EMBASSY Trust Suite

 

Windows 7 (32 and 64 bit), Vista 64 bit and XP 64 bit Operating systems are not supported environments for this software.

For supported Dell platforms and operating systems, Dell provides ETS as a free download on their support site Support.Dell.Com under Drivers and Downloads.  Enter your appropriate environment information for security software and related drivers.

 

EMBASSY Trust Suite – Acer Edition

 

Acer representatives are familiar with their hardware and the Acer EMBASSY Trust Suite (ETS) version software and provide the initial support for machines with ETS provided on this platform. Please contact Acer helpdesk at: Support.acer.com.

 

EMBASSY Trust Suite – Asus Edition

 

Asus representatives are familiar with their hardware and the Asus EMBASSY Trust Suite (ETS) version software and provide the initial support for machines with ETS provided on this platform.  Please contact Asus helpdesk at: http://support.asus.com/techserv/techserv.aspx?SLanguage=en-us

 

EMBASSY Trust Suite – Enterprise Edition

 

To purchase the Enterprise EMBASSY Trust Suite – Enterprise version for use on most equipment equipped with a TPM chip (including Dell models) or self-encrypting drive, please see our website http://www.wave.com/products/ets for ordering information.
 

If the information provided above did not resolve your issue, or you have any additional questions please complete our Support Request Form